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THE ARROW TOOL - FLASH 

The Arrow Tool is used to select and move an item or multiple items on the Stage. The Arrow 

Tool is also used to reshape lines and shapes, as those users familiar with prior versions of Flash 

may remember. The Arrow Tool’s new neighbor, which is also an arrow, but a white one, is the 

Sub select Tool. Its debut in Flash was occasioned by the addition of the Pen Tool. Thus, it is 

most useful for moving and editing anchor points and tangents on Bézier curves, as well 

as single items. 

Use the Arrow Tool to reshape a line or shape by pulling on any unselected line (or shape), or on 

its end points, curves, or corners. The Arrow Tool is also used to select and move Flash 

elements, including lines, shapes, groups, symbols, buttons, and other items. Five options appear 

in the Option Tray when the Arrow Tool (A) is selected : Magnet (or Snap), Smooth, Straighten, 

Rotate, and Scale. 

The Arrow Tool and its five options 



 

Using the Arrow Tool to select items 

The Arrow Tool is the primary selection tool in Flash. When you click a line or shape, a 

checkered pattern appears, covering it, to indicate that the line or shape has been selected. If the 

item is either a Symbol or a Group, a thin, colored border (called the Highlight) indicates 

selection status. This Highlight Color may be set in the Preferences dialog by choosing Edit⇒ 

Preferences⇒General. 

A shape, a group, and a symbol as they look both when unselected (the top items) and selected 

(the bottom items) shows below. The hatched pattern covers and surrounds the square indicating 

that it is a selected graphic, while the thin borders that surround the group and the symbol 

indicates that they have been selected. 

Using the Arrow Tool to select items Magnet 



 

In addition to clicking on a line to select it, you can also select one or more items by dragging a 

rectangular marquee over them using the Arrow Tool. This operation is called drag-

select. Additional items can be added to a current selection by pressing the Shift key and clicking 

the items. When you drag-select to select, previously selected items are deselected and excluded 

from the selection. To include previously selected items, press the Shift key as you drag-select. 

Deselect one or more items by using any of these methods: 

 Pressing the Escape key 

 Choosing Edit⇒Deselect All 

 Using the keyboard shortcut Ctrl+Shift+A (Command+Shift+A) 

 Clicking anywhere outside all the selected items 

Using the Magnet option of the Arrow Tool 

The Magnet (or Snap to Objects) option button is a toggle that causes items being drawn or 

moved on screen to snap to existing items on the Stage. Click the option button to toggle 

snapping on or off, or choose View⇒Grid⇒Snap to Objects. 

As shown below, the rectangular shape is being moved to the right with the Arrow Tool and is 

snapping to the invisible grid. When snap is turned on, Flash snaps the item to existing items. 

You can tell that an item is snapping by the presence of an o icon beside the Arrow mouse 

pointer. For some shapes, the icon or snap function will not work unless, when clicking to grab 

the shape before moving, the shape is clicked either at the center, corner, or side. 

Using the Magnet (Snap to Objects) option of the Arrow Tool 



 

The functionality and degree of precision of the Magnet (or Snap) button are controlled by 

settings that can be customized in the Grid field of the Grid dialog, which can be accessed by 

choosing View ⇒Grid ⇒Edit Grid. The settings are measured in pixels, relative to the movie size 

(not the screen size). 

Understanding shape recognition 

Shape recognition is the general term for a set of options that can be set to assist accurate 

drawing and manipulation of basic shapes. These options are the Smooth and Straighten options, 

which are used in conjunction with the Arrow Tool to clean up drawings by clicking their 

respective buttons to invoke their smoothing or straightening action. This is fully explained in 

the sections that follow. 

When used in conjunction with the Pencil Tool, more powerful shape recognition can be invoked 

the only real difference is that, with respect to the Pencil Tool, shape recognition processes the 

lines automatically. For example, a crude lumpy oval will be automatically recognized and 

processed into a true oval. 

For the Arrow and the Pencil Tools, both the degree to which shape recognition processes your 

drawings and also the strength with which the Smooth and Straighten options interact with your 

drawings may be adjusted with the Drawing Settings pane of the Editing tab of the Preferences 

dialog: Edit⇒Preferences⇒Editing. 

Here’s how shape recognition works with the Arrow Tool: Sketch something spontaneously (but 

not too wildly!). Then use shape recognition to transform your sketch into precision geometric 

forms. Start by sketching a rough circle, square, or rectangle. 

Then click the Arrow Tool and select the item you’ve just sketched. Then click either the 

Straighten or Smooth button to begin shape recognition. For hard edged items such as a polygon, 

click the Straighten option button repeatedly until your rough sketch is a recognizable and 

precise geometric form. For smoothedged items that approximate an oval, click the Smooth 

option button repeatedly until your rough sketch becomes an exact circle. 



Using the Smooth option with the Arrow Tool 

The Smooth option is a button that simplifies selected curves, as shown in Figure below. 

Smoothing reduces the number of bumps and variations (or points of transition) along the span 

of a complex curve so that the curve spans the same distance with fewer points. Repeated use of 

the Smooth button on a line results in a curve with only two points, one at either end. To use this 

option, a line must first be selected with the Arrow Tool, and then the Smooth button can be used 

to reduce the points in the selected line (or line segment). Action similar to the Smooth button 

can also be accessed by choosing Modify ⇒Smooth. 

Using the Smooth option with the Arrow Tool: The curve on the left was drawn with the 

Pencil Tool (in Ink Mode). 

 

Using the Straighten option with the Arrow Tool 

The Straighten option is a button that is used to make selected line segments less curved. The 

Straighten button operates on the same principle as the Smooth button, except that it’s used for 

straightening (instead of smoothing) a selected line segment. Repeated use of the Straighten 

button turns a curvy line into a series of angled lines. Action similar to the Straighten button can 

also be accessed by choosing Modify ⇒Straighten. 

Below shows, the Pencil Tool (in Ink Mode) was used to draw the rough, freehand T on the left. 

After selecting this rough T by clicking with the Arrow, the Straighten option button was clicked 

once to create the refined T shown on the right. 

Using the Straighten option with the Arrow Tool 



 

Using the Rotate option with the Arrow Tool 

The Rotate option enables you to rotate, skew, or slant a selected line, group, symbol, or item. 

With the graphic element selected, click the rotate option to put it into Rotation Mode. Eight 

circular handles appear. Drag a corner handle to rotate the item. Drag either a middle or side 

handles to skew or slant. You can also rotate items by choosing Modify ⇒Transform ⇒Rotate. 

Below shows, the Rectangle Tool was used to draw the square shown at the upper left. After it 

was selected by clicking with the Arrow Tool, the rotate button was clicked, resulting in the 

superimposed checker pattern and bounding box with eight circular, draggable handles, as 

shown at the upper right. Then, the square was rotated counterclockwise by click-dragging one 

of the four circular handles located at the corners of the square, as shown at the bottom left. 

Click-dragging any of the four internal handles (the handles not on the corners) results in a 

skewing of the shape, as shown at the bottom right. 

Using the Rotate option with the Arrow Tool 



 

Using the Scale option with the Arrow Tool 

The Scale option button enables you to scale or stretch a selected line, shape, group, symbol, 

button, or other item. With the graphic element selected, click the Scale button. Eight square 

handles appear around the selected graphic element. Click and drag a corner handle to scale the 

item. Click and drag either a middle or side handle to stretch the item. You can also scale by 

choosing Modify ⇒Transform ⇒Scale. 

After drawing the square on the upper left with the Rectangle Tool, the square is first selected 

with the Arrow Tool and then the Scale button is clicked, resulting in the superimposed checker 

pattern and bounding box with eight square, draggable handles, as shown at the upper right. 

Clicking and dragging on any corner handle, as shown at the lower left, symmetrically resizes 

the square. Asymmetrical scaling is accomplished by clicking and dragging on any of the side 

handles, as shown at the lower right. 

Using the Scale and Rotate dialog 

Choosing Modify⇒Transform ⇒Scale and Rotate elicits a dialog that combines the properties of 

both the Rotate and Scale option buttons in one dialog, enabling you to input numeric values for 

the amount of scale and transformation. (It’s very much like the Photoshop Numeric Transform 

Tool.) The keyboard shortcut for this hybrid is Ctrl+Alt+S (Command+Option+S). This 

functionality is further duplicated in the Transform Panel (Window ⇒Panels ⇒Transform). 

Although using either numeric transform dialog may seem unintuitive and hard to use unless you 



already know what you want to accomplish, they are extremely valuable for repetitive production 

tasks. 

Using the Scale option with the Arrow Tool 

 

Using arrow states to reshape and reposition drawings 

In addition to the actions accomplished by selecting a line (or line section) and clicking an 

option, three arrow states Move Selected Element, Reshape Curve or Line, and Reshape 

Endpoint or Corner enable you to reshape and move parts of your drawings. It works like this: 

As you move the Arrow Tool over the Flash Stage, the Arrow Tool changes the state of its cursor 

to indicate what tasks it can perform in context with various items (the line or fill) closest to the 

Arrow Tool’s current position. 

Below shows a series of images that demonstrate the various Arrow states in context with several 

kinds of shapes. These shapes are a filled shape, a brush stroke, and a brush stroke with an 

outline applied. In the upper left, the Move Selected Element Arrow state appears when the 

Arrow is passed over either one of these shapes. In the upper right, the Reshape Curve or 

Line Arrow state appears when the Arrow is hovered over any line or over the perimeter of a 

brush stroke. At the lower left, the Reshape Endpoint or Corner Arrow state appears when the 

Arrow is hovered over a corner. At the lower right, an Arrow state cursor is being used to 

reshape each item. 

Using Arrow states to reshape and reposition items 



 

Below it shows the completion of the reshape operations indicated above. 

The changes resulting from the reshaping shown above. 

 

To make your reshaping go even easier, try these techniques: 

 ress the Ctrl+Alt (Command+Option) keys, click a line or segment of a line, and drag to create 

a new corner point. 

 Selected lines cannot be reshaped. Click anywhere (outside all selected items) to deselect, and 

then reshape the line by clicking it with one of the different states of the Arrow Tool. 

 Smooth complex lines to make reshaping easier. 

 Increase magnification to make your reshaping easier and more accurate. 

 Prior to reshaping, select any group of elements (as a multiple selection, using Shift+select) 

that you want to change in unison. 



Moving grouped and ungrouped elements with the Arrow Tool 

Text and Groups are selected as single elements and move as a single unit. After you create text 

in a given frame, Flash treats the text as one block, or group, meaning that all the individual 

letters move together when the box is selected. Similarly, a group of graphic elements such as 

lines, outlines, fills, or shapes can be grouped and moved or manipulated as a single element. 

However, when you move an item that is not grouped, only the selected part is moved. This can 

be tricky when you have ungrouped fills and outlines, because selecting one without the other 

could result in detaching the fill from the outline or vice versa. To move separate elements (such 

as a rectangular line and its colored fill area) in the same direction simultaneously, group them 

first. To group separate elements, first select them all, and then group them with Modify 

➪Group. If necessary, they can be ungrouped later. 

Duplicating items with the Arrow Tool 

The Arrow Tool can also be used for duplicating items. Simply press the Alt (Option) key while 

dragging a selected item (or line segment) with the Arrow Tool. The original item remains in 

place, and a new item is deposited at the end of your drag stroke. 

 


	CS1st Year
	Multimedia & Animation
	REETA
	22/04/2020
	THE ARROW TOOL - FLASH

